modules Payline pour WooCommerce 1.x et 2.x

S’abonner
Les module Payline pour WooCommerce permettent une mise en œuvre rapide de la solution Payline dans votre boutique.
 
version wooCommerce module Payline à utiliser
2.3 à 2.6.4 woocommerce-payline_v1.3.3.zip
2.1 woocommerce-payline_v1.2.zip
2.0 woocommerce-payline_v1.0.zip
1.x wooCommerce16_Payline.zip
 
Vous avez d’autres questions ? Envoyer une demande

Commentaires

  • Avatar
    Fabien

    Bonjour,

    Oui woocommerce-payline_v1.0.zip est fait pour WooCommerce 2.0
    Il est compatible avec tous les moyens de paiement que nous proposons. Quel problème rencontrez-vous avec Paypal ?

  • Avatar
    alexandreaazzouz

    Sur le centre d'homologation j'ai programmé un moyen de paiement par carte et un avec paypal, quand je fais ma commande j'arrive bien sur la page du choix de paiement mais quand je choisis paypal il me retourne transaction refusée ou rejetée. Avec la console firebug je vois ces erreurs :

    SyntaxError: invalid regular expression flag s

    var url = /webpayment/servletProxy.do?reqCode=init;
    step1.do (ligne 71, col. 24)

    SyntaxError: syntax error
    setTimeOut(
    step1.do (ligne 1, col. 11)

  • Avatar
    123dev

    Bonjour,
    suite à la mise à jour de woocommerce en version 2.1.5 et Wordpress en version 3.8.1 nous avons une Fatal Erreur au moment de solliciter le module de paiement dans le tunnel de la commande :

    Fatal error: Cannot use string offset as an array in /homez.763/epicrepo/www/wp-content/plugins/woocommerce-payline/class-wc-gateway-payline.php on line 570

    Cette erreur apparait sur la page du site qui déclenche l'appel à payline, lorsque l'on a choisi "Paiement par Payline" dans la commande.

    Avez-vous une mise à jour disponible du module "Payline 1.0" pour woocommerce ?

    Merci
    Olivier

  • Avatar
    123dev

    En fait il semble que la ligne qui récupère Payment > Curency pose un pb. :

    $doWebPaymentRequest['payment']['currency'] = $this->_currencies[$order->order_custom_fields['_order_currency']['0']];

    pour le moment j'ai fixé "en dur" cette variable à 978 et cela passe.

  • Avatar
    Fabien

    Effectivement sous WooCommerce 2.1 les données de la commande ne sont plus stockées de la même façon. Je regarde ça pour proposer un module propre

  • Avatar
    123dev

    OK merci !

  • Avatar
    Fabien

    Voilà ! La version 1.1 de notre module pour wooCommerce est en ligne sur http://www.payline.com/index.php/integrez/modules-e-shop-et-kits
    La devise, le montant de la commande et des taxes sont récupérés de façon conforme à wooCommerce v2.1
    J'ai également ajouté l'envoi du contenu du panier.

  • Avatar
    123dev

    Merci Fabien. Super, je vais tester.

  • Avatar
    123dev

    Ça fonctionne au moins pour l'appel du formulaire Payline de paiement. Je verrai le traitement du retour à la prochaine commande.
    Merci pour votre travail.

  • Avatar
    Hugo Cavaleiro

    Hello,

    We've installed Woocommerce 2.2.8 and installed woocommerce-payline_v1.1.zip but the plugin shows an error on top of the page: Notice: Undefined index: ctx_mode in .../plugins/woocommerce-payline/class-wc-gateway-payline.php on line 224.

    Is there a way of getting rid of this error in particular?

    Thanks in advance.

Réalisé par Zendesk